DPChallenge: A Digital Photography Contest You are not logged in. (log in or register
 

DPChallenge Forums >> Hardware and Software >> 30D Shutter problem?
Pages:  
Showing posts 1 - 10 of 10, (reverse)
AuthorThread
11/04/2007 12:06:08 AM · #1
Can anybody shed some light on a shutter problem i am having.

When pressing the shutter button down, the camera auto focuses but doesn't fire straight away. Sometimes it takes half a second. Sometimes up to as much as 5 or 6 seconds.

I have tried in Manual focus. Tried changing different lenses. Tried changing and recharging the battery.
Has anybody had this problem and is it an expensive problem?

Thanks
Lee
11/04/2007 12:37:58 AM · #2
It may help to know if you are seeing any other warnings on the screens or in the viewfinder in order to know more about the problem. It may be that you have it on spot focus or spot metering, and sometimes you are focusing on a place where the light isn't that bright.
I have also experienced accidentally leaving the camera set to self timer, and it took me a very nervous while to figure out what was going on. Duh? : )
In any case, I hope that it is just a setting and not something serious.
11/04/2007 01:09:53 AM · #3
yeah i have it too. i only use the shutter button for metering and firing (i have focussing set to the * button), but its only delayed in firing sometimes.
11/04/2007 01:16:59 AM · #4
I have a 30D that sometimes delays and sometimes doesnt fire at all. Soemtimes it is goofy over and over and sometimes it is only once in a while. It went through a period of getting much worse but right now it's much better and rarely messes me up. I also have a vertical grip with a second button that never fails my timing so I know it's the button on the camera and not the shutter mechanism. I have one more event to shoot and I will be sending it off to be repaired.
11/04/2007 01:41:59 AM · #5
If you have a remote, you can try it with that to see if the shutter button switch in the camera is going out.
11/04/2007 08:20:19 AM · #6
there isn't a problem with the shutter once the button engages. the problem seems to be the button.

anybody know if this is an easy fix?
11/22/2007 07:57:22 AM · #7
FYI

Turns out that under the shutter button there is a sensor plate with 4 sensors in each corner. 2 of these sensors (the ones closest to the side of the camera body) have been worn down and that is why it doesn't fire when pressing on that side of the button.

Easily fixed by replacing this plate BUT costs a couple of hundred bucks

Lee
12/11/2008 02:57:41 AM · #8
I fixed the intermittent shutter button problem with no parts needed.

Details provided here with some helpful images and links to detailed disassembly instructions:
//www.flickr.com/photos/shippelt/3099140135/

Photo:
' . substr('//farm4.static.flickr.com/3160/3099140135_0b021a32ab.jpg', strrpos('//farm4.static.flickr.com/3160/3099140135_0b021a32ab.jpg', '/') + 1) . '

Hope this helps!

-Ryan
12/12/2008 05:16:34 AM · #9
Basically took it all apart, clean the dirt/dust/corrosion on the contacts inside the button housing and put it back together.

I even went and made a video detailing the process!

//www.youtube.com/watch?v=CAWGScQeC5g

Hope you enjoy and can use it to try yourself in the future :)

Message edited by author 2008-12-12 05:16:52.
12/13/2012 11:14:50 PM · #10
I had a similar problem with my rebel XS, various shutter button problems, even did the alcohol thing, almost considered sending it for repair.

The solution:

go to custom functions menu No7(Auto Focus /Drive AF during Live shooting)

Then choose option 2: Live mode

Now my camera is working fine.
Before I did the steps above, I did play with the live view manual and auto focus for a while and that is how I bumped in to the solution.

I really hope this works for you as it did for me.
Pages:  
Current Server Time: 01/22/2021 11:49:40 AM

Please log in or register to post to the forums.


Home - Challenges - Community - League - Photos - Cameras - Lenses - Learn - Prints! - Help - Terms of Use - Privacy - Top ^
DPChallenge, and website content and design, Copyright © 2001-2021 Challenging Technologies, LLC.
All digital photo copyrights belong to the photographers and may not be used without permission.
Proudly hosted by Sargasso Networks. Current Server Time: 01/22/2021 11:49:40 AM EST.