DPChallenge: A Digital Photography Contest You are not logged in. (log in or register
 

DPChallenge Forums >> Tips, Tricks, and Q&A >> Invalid JPEG marker?
Pages:  
Showing posts 1 - 18 of 18, (reverse)
AuthorThread
01/23/2005 01:11:32 PM · #1
I have some images that I access. I can't see a preview and when I try to open them in PS CS I get an error that says, "Could not complete your request because an unknown or invalid JPEG marker type is found."

Anyone know what causes this and how I can get around it to access the pics?

Thanks for your help!

Jen
01/23/2005 01:13:41 PM · #2
Thanks for asking this question Jen. I have the same problem. I downloaded some recovery software last night and it will recover the "deleted" files just fine, but this is the situation (the one you described)I get for the "moved" files.

Hope someone has some help for us!
01/23/2005 02:56:29 PM · #3
The file may not actually be saved in JPG format.

If you save a file as TIFF format but leave the extension as JPG, it will preview in file browser just fine as a thumbnail, but will generate the error you describe when you try to open it.

If you use File -> Open As and select this file with a type of TIFF, it will open fine.

So, at a guess, it sounds to me like your JPG is not really a JPG but some other file format saved with a .jpg extennsion. One possible scenario anyway.

Good luck!
01/23/2005 03:17:41 PM · #4
Rich, thanks for the suggestion. I just tried several to "Open As" with several different file types and none of them worked.

Anyone else?
01/23/2005 03:23:30 PM · #5
I used to have this problem when saving pics using PhotoSuite. Upon checking in Explorer, the saved file would be there, but without its file extension...jpg. Due to this, windows didn't know what programme to assign it to.

Rememdy, if it is showing in explorer without extension...rename it with jpg extension. Also, try adding that extension anyway...it may read aaa.jpg.jpg...then you have to try something else.

It could be that simple, saving without jpg extension.

Best of luck sorting it.

Steve
01/23/2005 03:32:50 PM · #6
Thanks, Steve. Tried that to with no luck also. :-( Thanks for replying though.
01/23/2005 03:36:52 PM · #7
Originally posted by ButterflySis:

Thanks, Steve. Tried that to with no luck also. :-( Thanks for replying though.


Do the files open okay in Explorer? If so, are they corrupted...not fully copied?

Just trying to think this thru.
01/23/2005 03:50:03 PM · #8
Originally posted by Formerlee:

Originally posted by ButterflySis:

Thanks, Steve. Tried that to with no luck also. :-( Thanks for replying though.


Do the files open okay in Explorer? If so, are they corrupted...not fully copied?

Just trying to think this thru.


They are all tagged with .jpg and do not show as thumbnails, do not open from Explorer (in the XP fax and file viewer thingy), and do not open in PS.

Thanks for your help. These files are actually from July and I've been holding on to them in hopes of finding an answer. I'm searching the Net as well.

Jen

Maybe they diddn't
01/23/2005 03:53:56 PM · #9
You can mail me one, if you want, and I will try opening it or at least checking it out.

Steve
01/23/2005 03:54:46 PM · #10
Ditto. I'd be happy to look at one of the files.
01/23/2005 04:49:49 PM · #11
Thanks for the offers guys! I'll email one.

I've been playing with IrfanView and PIE (Picture Information Extractor) and I think the image files are basically empty from what I can tell. For example, in IrfanView's hex viewer all of the data shows as zeros where as when I open a normal image it contains all kinds of digits/characters. They won't open in Ascii viewer at all. With PIE, it says no exposure data available, the dimensions are 0x0, and the image type is unknown...but file size is not zero. Strange stuff.

Thanks again. I really appreciate your help.
12/07/2007 11:47:41 AM · #12
Hi Guys - I am having the same problem all my photos (jpeg)are not possible to open anymore. Dosen't matter what software I use.... All I get is this error message "invalid jpeg marker" Do you know how to recover/open these images? Is there any software that recover jpeg files??
Also, all the photos used to be ok. After downloading them to the computer I was able to open all of them for months. But after I formated the computer (the C drive)(I removed all the photos to another disk first!)none of them are possible to look at... (I copyed them back to the same location where they used to be on the disk that i formated.
I have tried everything!

Please help.
08/07/2008 09:41:44 PM · #13
was it a 16BIT image?
12/15/2010 02:51:18 PM · #14
ok very simple, open file in paint, save as any format u want and rename just in case, the new file will open everywhere
05/22/2013 12:02:02 PM · #15
I took about 500 photos from a family event. The first 350 turned out fine. Not sure what happened in my camera but the remainder of the photos could not be viewed in camera, when I put them on my computer they do not show a preview in windows explorer. I haven't found a program that will open them. I have tried Adobe Photoshop CS5, Paint, Lightroom, Ifranview, and the list goes on. I was hoping maybe someone figured out how to fix this problem. I would really hate to lose these photos. I don't have many with my father.
05/22/2013 12:02:02 PM · #16
I took about 500 photos from a family event. The first 350 turned out fine. Not sure what happened in my camera but the remainder of the photos could not be viewed in camera, when I put them on my computer they do not show a preview in windows explorer. I haven't found a program that will open them. I have tried Adobe Photoshop CS5, Paint, Lightroom, Ifranview, and the list goes on. I was hoping maybe someone figured out how to fix this problem. I would really hate to lose these photos. I don't have many with my father.

Message edited by author 2013-05-22 12:05:54.
05/22/2013 12:09:58 PM · #17
Originally posted by raylan_ashley:

I took about 500 photos from a family event. The first 350 turned out fine. Not sure what happened in my camera but the remainder of the photos could not be viewed in camera, when I put them on my computer they do not show a preview in windows explorer. I haven't found a program that will open them. I have tried Adobe Photoshop CS5, Paint, Lightroom, Ifranview, and the list goes on. I was hoping maybe someone figured out how to fix this problem. I would really hate to lose these photos. I don't have many with my father.


The files that were transferred are corrupt. There is no fix for the transferred files, however if you have not re-used the card, there may be hope. Do the following, in order:
1.) Try reading the card on another computer, with a different reader, etc. and see if the files are then OK if not, proceed to (2)
2.) Use file recovery software to recover all image files on the card.
Do not in any circumstances write any files to the card until you are sure that you have recovered everything you can from it. Also, be aware that if files on the card got corrupted, it may be the card. Be careful using that card for anything you can't afford to lose!
05/22/2013 12:41:49 PM · #18
I've been having a similar prob from PS to bridge, saved them and then can't open it back up... As long as I haven't closed PS with the edited shot on it I can save as a copy and it opens and shows just fine???? I have no idea, but the save as a copy thing works every time...
Pages:  
Current Server Time: 09/25/2020 09:08:08 AM

Please log in or register to post to the forums.


Home - Challenges - Community - League - Photos - Cameras - Lenses - Learn - Prints! - Help - Terms of Use - Privacy - Top ^
DPChallenge, and website content and design, Copyright © 2001-2020 Challenging Technologies, LLC.
All digital photo copyrights belong to the photographers and may not be used without permission.
Proudly hosted by Sargasso Networks. Current Server Time: 09/25/2020 09:08:08 AM EDT.