DPChallenge: A Digital Photography Contest You are not logged in. (log in or register

DPChallenge Forums >> General Discussion >> Canon 5D Mark IV main dial not working
Showing posts 1 - 8 of 8, (reverse)
11/09/2019 12:51:21 PM · #1
The Main Dial (one next to shutter button) has stopped working on my 5D Mark IV. It still moves - but doesnít do anything.

I have tried a factory reset, removing battery and memory cards overnight etc but makes no difference.

I am worried this could be due to water damage as recently have had a few wet incidents - one a couple of weeks ago where I stepped in a puddle on Exmoor right up to my waist and camera got very wet and stupidly I didnít do anything with it when I got home. Another day it got very wet as I stayed out in heavy rain for 3 hours waiting for deer.

Just wondered if anything else to try before sending in for a repair quote?


11/09/2019 12:54:44 PM · #2
Besides the regular battery there should be one of those coin-shaped ones hidden somewhere (maintains settings when camera is off); you might try changing that.
11/09/2019 01:01:52 PM · #3
Thanks Paul for the suggestion. I did think of that but then read the following

ď Canon stopped using removable, user serviceable date/time backup batteries in the EOS line sometime in mid-2012.

The last cameras I checked that had one are the 5D Mark III and 1D X. Both released in early 2012.Ē
11/09/2019 01:43:20 PM · #4
Interesting... my top dial behaves a little intermittently. It works almost always, but fails to advance the setting on some movements. It seems to me to be a mechanical issue, not electronic. If you didn't have any intermittent behavior, then I'd guess your issue has a different root cause. If you did have intermittent behavior, perhaps there is a shared cause. Mine has not misbehaved enough to warrant a repair.
11/09/2019 01:52:06 PM · #5
Thanks for rhe reply Kirbic

It is a bit intermittent but only started a week or so ago. In that time it has started working again but for last 2 days it hasnít worked at all. So perhaps a similar issue. Not much comes up on google for this issue tho.

Message edited by author 2019-11-09 13:52:45.
11/09/2019 03:00:02 PM · #6
Sorry, canít help you Paul. I usually figure if the camera is not doing what I want itís something Iím doing wrong not the camera:(
11/09/2019 04:47:54 PM · #7
Thanks Lawrence. My first thought was I had accidentally changed a setting but I am pretty sure this is not the case. The M-FN button next to the dial also seems not to press as smoothly as it does on my 5D Mark iii which could be just a red herring

11/19/2019 05:13:35 AM · #8
Just to update anyone interested.

I sent my camera into the authorised Canon repair centre and they have repaired it as follows:



Cost was a couple of hundred pounds so not too painful.
Current Server Time: 12/12/2019 12:10:33 PM

Please log in or register to post to the forums.

Home - Challenges - Community - League - Photos - Cameras - Lenses - Learn - Prints! - Help - Terms of Use - Privacy - Top ^
DPChallenge, and website content and design, Copyright © 2001-2019 Challenging Technologies, LLC.
All digital photo copyrights belong to the photographers and may not be used without permission.
Proudly hosted by Sargasso Networks. Current Server Time: 12/12/2019 12:10:33 PM EST.