DPChallenge: A Digital Photography Contest You are not logged in. (log in or register

DPChallenge Forums >> Tips, Tricks, and Q&A >> Memory card cannot be accessed
Showing posts 1 - 12 of 12, (reverse)
02/06/2015 02:48:54 PM · #1
I have a Canon EOS 700D and I have a 8GB SD card which I bought like a month ago. A week ago I was transferring the photos on the card on to my mac and I used the built in card reader. After I imported everything through iPhoto I clicked on \'\'Delete images on card\'\' and it all froze and stopped working so I had to force iPhoto to close. After that I inserted the card in my camera and suddenly I got a message telling me \'\'Card cannot be accessed. Reinsert/change card or format card with camera\'\'. I was so confused, I tried reinserting the card several times and I also formatted the card (but I did it through my mac :S) Now the card won\'t work and I don\'t know why. I\'ve read a couple of threads everywhere and some say that it could be a pin which is bent, but I don\'t know if it\'s bent so I\'m going to show you a picture of the card reader in my canon. The card works when I put it in the card reader in my mac, but there aren\'t any files there. I tried putting the card in my other camera, Sony a55, and I got the same message there so I\'m hoping it\'s the card and not the camera itself because I bought the camera just a month ago. I really hope some of you can help me and tell me what to do and tell me if any pins are bent or broken?

picture of my camera card reader: (www.)s15.postimg.org/jjg6umo63/Skjermbilde_2015_02_06_kl_20_40_23.png

Message edited by author 2015-02-06 14:50:06.
02/06/2015 03:01:38 PM · #2
Format the card in the camera, not on your computer.
02/06/2015 03:04:21 PM · #3
Have you tried a different card in the camera to test the camera itself? You already formatted the card with the mac, but did you format the card with your camera? Try that out...

Since you formatted the card, you probably won't get your data back.

If it is the card that turns out to be broken and not your camera, an 8GB SD card runs about $5-$10.
02/06/2015 03:04:32 PM · #4
I have tried, but since the card cannot be accessed it didn't work to format in on the camera either. It just says ''Can't format card.''
02/06/2015 03:12:35 PM · #5
SD cards don't have pins -- they use a flat contact.

If the card will still mount in the card reader on the Mac see if there is any way to format it as FAT32 (old PC format) which is what most cameras use. Your camera probably can't access it because you formatted it as a Mac volume.

If you can't do this try and find someone running Windows and see if they can format it for you. If not, the card may just be too corrupt to be worth fixing ...
02/06/2015 04:02:13 PM · #6
I just bought a new card and it still doesn't work..
02/06/2015 06:06:29 PM · #7
this may sound silly but are you sure you're not forcing the card in upside down? Some cameras, the contacts point up, some they point down. Theoretically a card won't go in the wrong way but if you mash it in you can overpower that :-(
02/06/2015 06:20:13 PM · #8
Yes, I'm sure I'm not doing that :P It goes in easy and I haven't used a lot of strength trying to pull it down. I've been really careful, that's the reason I'm so confused. I really don't know why it's not working.
02/06/2015 07:11:11 PM · #9
Camera still under warranty? Sounds like the problem could be in the card slot...
02/06/2015 07:59:06 PM · #10
Hope you get it sorted out soon. One thing that has happened to me is that the thin insulator between the contacts on one of my cards got out of place on the card, but the 2nd card should have solved that.
There is a chance that there is some kind of junk in the S D slot on your camera.
On S D cards, there is a little slider, usually white, on the side of the card near the front left corner. That locks the card when it's pulled back. It touches a lever in the device to tell the device that it's ok to read & write the card. They also sometimes drop off the card. Look with a light into the card slot, or shake/ bump the camera with your palm with the opening down to see if anything falls out.
If you put the card in your Mac, make sure that you eject it properly, from Finder.
You may be able to do something with it if you put it back in the Mac and open "Disc Utility", do a repair on it, then check to see if it contains any image files. When done, format it to FAT 32 using Disc Utility, and eject it before you pull it out.
You may also try doing a full reset on the camera. It's a little more complicated than just a "reset settings". One of the Canon people can tell you how to do that.
One last thing, try putting a card in the camera, then connect it to your Mac with a usb cord, and open "Image Capture" in applications in the finder. It may find the camera and load any missing photos.
Make sure that you are getting 10X speed cards too. Some of the newer cameras will not work with the older slower 4 or 6X speed cards, esp with video.
Good luck with the problem.
02/06/2015 08:06:55 PM · #11
Originally posted by MelonMusketeer:

Make sure that you are getting 10X speed cards too. Some of the newer cameras will not work with the older slower 4 or 6X speed cards ...

Gotta say, I can see an older camera not working with a newer/faster/bigger card, but not working with an older smaller card is just stupid.

I did suggest formatting in FAT32 but I wasn't sure if it could be done using the MacOS ...

Message edited by author 2015-02-07 10:01:52.
02/07/2015 12:34:17 AM · #12
True, most if not all will work for still shots with any speed or size card, but some of the newer cameras refuse to shoot video with slower cards.
One of my friends hit that wall the day she was supposed to video a wedding last year. Fortunately we got it figured out by reading the manual in time, and getting her a couple of faster cards.
Current Server Time: 07/16/2019 01:00:26 PM

Please log in or register to post to the forums.

Home - Challenges - Community - League - Photos - Cameras - Lenses - Learn - Prints! - Help - Terms of Use - Privacy - Top ^
DPChallenge, and website content and design, Copyright © 2001-2019 Challenging Technologies, LLC.
All digital photo copyrights belong to the photographers and may not be used without permission.
Proudly hosted by Sargasso Networks. Current Server Time: 07/16/2019 01:00:26 PM EDT.